読者です 読者をやめる 読者になる 読者になる

【Ruby on Rails】 bundle installで'could not locate Gemfile'というエラーが出る

スポンサーリンク
広告
Railsのbundle installをしようと思ったら、"could not locate Gemfile"というエラーが出た。
そのエラー文をそのまま検索すると、ばっちりのStack Overflowのページに行き当たった。
答えもばっちり書いてある
 
こちら↓
You do not have Gemfile in a directory where you run that command. Gemfile is a file containing your gem settings for a current program. 直訳すると、「ジェムファイルがそのコマンドを実行させているフォルダにありません。 ジェムファイルっていうのは、現在のプログラムのジェム設定を含んでいるファイルです。」という感じ。
そのとき持った感想は、「それは、それはわかっているんだけど・・・」。
 
当たり前のこと過ぎて、それはわかっているんだがなぜエラーが出るのかわからん! と思ってしまった。
 
そして、5分後。
あ、bundle installを実行するときの、ディレクトリ間違えてた。
階層一個下だった・・・!!!
 
ちゃんちゃん。
こういった初歩的なエラーをこれから何千何万と乗り越えて、ものを作れるようになっていくんだろうな、と実感した。